Can't add a decimal value to a script property of type "number"

Describe the bug:
I try to add a decimal value to a script property of type “number”. So I type “1.25” and press Enter. The value will then save as either 1 or 2.

This seems to be caused by Windows language settings. When opening the editor I sometimes see decimal values with a dot (.), and sometimes with a comma (,). But I can’t add either of those.

One time I could enter a dot, but I’m not sure why. It might be that the current Windows keyboard layout on Crayta startup has to match. I have 4 different Keyboard Layouts (German, ENG with German Keyboard, ENG with US Keyboard, and Chinese). Switching between keyboard layouts while Crayta is open does not help.

How do you cause this bug?

  • Add a script property with type number. Try to fill in a decimal number value.
  • A requirement might be to have a different language keyboard layout installed.

Which platform: This bug only occurs on PC. Stadia always worked for me.

Which input: keyboard + mouse

Your Crayta username: Vilva#9953

Game seen in (including “Hub” or “Editor for XYZ”): Editor for Sky Island Adventure

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible): Almost every time

Time + date seen: 14.11.2021

Version number (found in Help tab in Settings): 0.d5.9.111485

Hi Vilva,

This has already been raised as an issue by the community, I think it was directly on Discord this was discussed. It looks like the fix has been made, but won’t be implemented until an upcoming patch. This is likely to be in for the new battle pass.

1 Like

Hi Stuart,

thanks for the info :slightly_smiling_face:

I just put the description here to make sure it doesn’t get lost.