Editor Rendering Settings Override Broken

Describe the bug:
Prior to Neon Coast, the “Editor Rendering Settings Override” option under the World tab could be used to turn off all shadows, disable fog and brighten up the map so every angle/side of a voxel is visible. This was incredibly useful working in dark spaces. Since the release, this button seems to set a morning type sun which actually causes more darker shadows - it also does not disable the fog or color grading/postprocessing. Without this option, it is incredibly difficult to see in dark spaces and build easily. It can be very frustrating building detailed worlds without this as I cannot see what I am working on properly due to shadows. As a very detailed oriented builder, I miss this feature dearly and have to take regular breaks from voxel building due to eye strain looking for edges/corners. I would be incredibly grateful to have this back. Thank you for your consideration.

How do you cause this bug?
Put in world settings - fog, color grading, post processing and sun shadows. Attempt to temporarily disable them with this option. “Editor Rendering Settings Override”

Screenshots / video of bug:
All three of these surfaces are the same voxel material but they all appear differently.

Which platform: PC / Stadia
PC

Which input: Controller / keyboard + mouse
KBM

Your Crayta username:

Game seen in (including “Hub” or “Editor for XYZ”):

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible):
3/3 since neon coast release.

Time + date seen:
September 18th 2021

Version number (found in Help tab in Settings):
0.7.639.110013

(PC only) hardware specs (upload dxdiag file if possible - Open and run DxDiag.exe):

Remember!
The more information you provide, the more likely it is that this bug can be fixed quickly! Also, if this was discussed in Discord / Reddit / elsewhere, it might help to include a screenshot of that discussion!

1 Like

Hello Dry_Coast,

Thank you for bringing this issue to our attention.
I have submitted a ticket to our internal team to review. :slight_smile:

This has been fixed in next patch!

1 Like

I am relieved to hear the fix is incoming. This has been quite the struggle for me lately as I have pretty poor eyesight.