[Fixed] Errors / Issues With Create.Crayta.Com

From talking with some of the other folks in Discord, and based on some of the onscreen messaging, it seems like this issue might be related to just my account. This issue is a little hard to summarize clearly, so I’ve made a video to accompany this post. It’s possible I’m doing something completely wrong, but I can’t seem to get the create.crayta.com website to work for me.

Things I’ve tried:

-Removing all extensions.
-Using the site in incognito mode.
-Using the site on a completely different computer. Interestingly, that computer shows the games I’ve created, but the upload functionality does not work still.
-Both Chrome 84 stable & beta 85 (85.0.4183.38)

Video link (unlisted): https://www.youtube.com/watch?v=B-61OTVAKdI
DXdiag: https://drive.google.com/file/d/1Ipjlrs1NtIK8BNsc_oMrq8oc2mrgxR61/view?usp=sharing

Any help/guidance would be appreciated. Thanks!

1 Like

In the Incognito Mode I noticed the little “pop-up blocked” icon. You should click that when it shows up to see if at least you can get it to redirect in incognito mode.
image

As for normal mode: first check out the Chrome settings to see there are any permissions specific to Crayta that are disallowed.
If you are using an ad blocker (I’m assuming the green circle is an add blocker, but I don’t recognize it) I also recommend turning that off for this domain specifically.

Hope this helps!

Hi @Twenty9,

We had an issue with SameSite cookies on the website. The problem depends on how strictly your browser is treating them. But it should be fixed now.

T.

1 Like

@Yogarine Thanks for the pointers. I actually didn’t catch the popup block notification for incognito. I was able to login successfully in Incognito after adjusting my settings. I also went through and explicitity allowed everything permissions wise for the create.crayta.com site. Unfortunately I still seem to be experiencing the same issue.

@U2GTom Thanks! This seems better. I no longer experience all the visible ‘error’ messaging, and I can see the games I’ve created now in the UI, but I can’t upload images still. After I click the ‘Select File’ button, the file dialog appears and I can pick my image file that I want to upload. After I choose my file, the dialog closes and I’m returned to the page as expected, but there is no UI change and it appears that nothing has happened.

If I open up the browser’s developer console, I can see the following error 500 response from (https://devel.gate.live.us-central1-a930.hogsmill.ws.crayta.net/content-upload/createImage):

GameProfileViewErrorCodes.NO_GAMES_OWNED

Let me know if there’s anything I can do from my end to lend a hand. Thanks for looking into this!

Just in case it’s helpful, here’s a link to a shared folder with the images I’ve been trying to upload:
https://drive.google.com/drive/folders/1G3C8dxquWZltRR_OF45eGAMJypFo03nw

1 Like

I’m having this exact same issue. Waiting for the fix :crossed_fingers:

And so am I! We’ll get this looked into as a priority, thanks for reporting it :+1:

Ok, so this one is getting weird. Our web systems engineers were debugging the issue with me and we’ve found that the images are uploading for me today - even though nothing has changed!

Can someone else try again please, and let me know either way if it now works or doesn’t? We’re quite keen to find someone who is still suffering fro the problem so that we can continue to debug through the issue.

Nop, not yet… Is this true black magic???

I could send you a failing CURL request by DM if you want me to.

Hi @heedrox! No need to send the curl, we have found the bug. Unfortunately our system is blocking you until you have at least one published game and this was not our intent. We’ll change this to just require at least one game, regardless of whether it is published, and roll out a fix shortly.

A workaround for now would be to publish a game and try uploading the image again. This can be an new empty game for now if you don’t want to publish the game you are working on.

Sorry about this. Hope this works for you.

2 Likes

That worked! Thanks!

3 Likes

The fix for this has been deployed, it should no longer be an issue for anyone else.