Game Preview not working correctly from editor

When trying to preview the level from editor, it doesn’t work correctly. No character appears and controls seems to be stuck on drone editor with no interaction capabilities. Thank you

Make sure you have a locator anywhere in your entity tree.

To select a spawn point, go to advanced mode and go to Templates -> User -> Spawn

Make sure under spawnPoint, your locator (where you want to spawn) is selected.
Also check in under playerTemplate, your player template is selected. (Player template is called just ‘player’ unless you manually changed it.

Let me know if you managed to figure it out, otherwise I’ll be able to jump in your editor and see what I can find.

1 Like

Thank you for replying to my bug. Sorry it took so long for me to reply. I’m still getting use to game play and communicating.

I do have a locator on terrain that’s labeled Start location. That’s where I’ve been spawning from. I believe I started with an adventure type game that came with a few things. It worked well up to about month and a half ago.

My User template doesn’t have a Spawn folder.

I haven’t been worried about it up to this point, but I’m almost done building my environment and am looking to move forward on my UI and scripts soon.
I have attached a few recent screenshots of my game that I’m working showing what my User template looks like and how the world tree has formed up to this point.



Thank you for your help. I appreciate it very much. When you’ve got some time could you jump into my editor and see what you can do. In the mean time I’ll be in my game tidying up my tree. :grin: :+1:

Thank you!

Hello again,
Hope your not too busy. I am back having the same problem with previewing my game from editor. I have come to a conclusion. Either my game that I’m creating is haunted/possessed or there is a gremlin in my game that prevents me from previewing my game. LOL! I’ve also went on discord and tried troubleshooting the problem. I thought I solved it because I could finally see and control my character, yet it still showed my editor inventory. I investigated further and determined that the issue has nothing to do with my adventure script and something to do between my player/user inventory and editor inventory. It definitely has something to do with inventory cause now when I go to preview my game the editor inventory is now gone. when I bring up my console by pressing O it shows no errors and that the 3 original items that were on my player inventory was loaded successfully. If you have any insight how I can switch from editor mode to player mode in game preview with those original items showing up when loaded would a great step forward for me. That way I would be able to preview for mistakes before I continue on my build. Thank you for your time.