Game world still renders while code editor is full screened

Describe the bug:

If you open the code editor full screen, the entire game world is still rendered in the background. This results in dramatically lower frame rates than necessary when editing code.

As a result, I’ve made it a habit of opening an empty template when in a large world, before opening scripts to edit because the frame rate is so much higher. This makes typing, highlighting, general editing much smoother.

How do you cause this bug?

  • This is easier to see in a large world
  • Open the game in create mode
  • Hit O, go to the performance tab, note the frame rate.
  • Open a script for editing such that it’s fullscreen - note the frame rate doesn’t change.
  • Now, create an empty template, and edit it. Notice the frame rate skyrockets because it’s not rendering anything. I believe this is the behavior a fullscreen code editor should have.

Screenshots:

Note the frames per second in each scenario.

In world:

In world, code open:

In template:

In template, code open:

Which platform: PC / Stadia

Your Crayta username: Cereal

Game seen in (including “Hub” or “Editor for XYZ”):

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible): Every time

Time + date seen: 2021-11-28

Version number (found in Help tab in Settings): 0.d5.9.111485

Hey there again @Cereal!

Thank you for bringing this to our attention. :slight_smile:
I have opened up another ticket for this issue for our team to investigate the issue further.

1 Like