Keyboard shortcuts and some keys not working on the code editor

Hello!


The keyboard shortcuts inside the code editor don’t seem to work.

By shortcuts I mean like: Ctrl + C, Ctrl + V, Ctrl + Z…

Also trying to enter {} or [], or characters with accents (á, é, …), or some special characters like “~” doesn’t work.

For some things I’ve been copying and pasting the characters that are available on the placeholder text on the new script files.

But for others I can’t do that. For example because I cannot enter ~ I cannot say “val ~= val2” and I have “not (val == val2)” which is harder to read.


More details:

  • Tested using Ubuntu 18.04 and Chrome 83.0.4103.116, using a desktop PC with USB keyboard (spanish layout, without numpad).

    • Shortcuts: not working
    • Other characters: not working
  • Tested using Windows 10 and Chrome 83.0.4103.116, using a Lenovo Ideapad L340 (spanish layout, full keyboard).

    • Shortcuts: working
    • Other characters: not working
1 Like

Yeah, there’s a known issue with non-English keyboards it’ll be fixed in the next patch.

2 Likes

Great!

Thanks for letting me know! :smile:

Changing the layout to english worked for special characters, but not for the shortcuts on Ubuntu.

2 Likes

Hello!

Coming back to let you all know that the issue with the shortcuts was due to a program in Ubuntu that was capturing the Ctrl key to show an effect on the cursor position.

I disabled this option in the program and the shortcuts now work!

The program is gnome-tweaks BTW in case someone else runs into this same issue.

:smile:

1 Like