Timelines desync

Describe the bug:
Sometimes after a bit of playing (hard to specify correctly, might be hour or half) timelines would get desynced between client and server. This causes problems by each and every timelined object even if they are deleted and recreated. Basically what is displayed on client is wildly different from what is happening on client. You would often hit something that does not seem to be hittable, because server thinks it is in a different place.

How do you cause this bug?

  • Use timelines ( f.e. PlayRelativeTimelineLoop ) to move collideable entity
  • Add trigger on your player to be triggered by that entity and notify you when trigger happens
  • Move around, Wait some time, etc

Eventually you should notice that client displays that entity differently than server thinks it is ,because trigger would start being triggered by a void before of after it (depends on how you set timeline).

Screenshots / video of bug:

Hits on 0:11 and 0:27 are totally result of this bug, because trigger is well inside of orb and being hit like this is definetly because of desync - client thinks that rotating block is in different position than it actually is.

Which platform: Stadia

Which input: keyboard + mouse

Your Crayta username: strowk

Game seen in (including “Hub” or “Editor for XYZ”): Editor for Turn Right and also when playing it

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible): maybe once in 20 times? Hard to say, it is pretty random, but once desync happened - every other timeline would be broken the same.

Time + date seen: 06-02-2022 and during the jam several times in preview

Version number (found in Help tab in Settings): 0.e4.49.115313

Hey there @str !

Thank you for bringing this to our attention! :slight_smile:
I have opened up a ticket with the information you have provided. Our internal team will investigate this issue further.

As for the the video; if its possible to save/upload them to another site due to the videos from the stadia.google appear to almost never work (when I go to look at them). I am assuming they are deleted after a certain amount of time- we are 98% of the time not able to view them. This will ensure that the videos you do link/upload are always readily available. (Pease and Thank You! :smile:)

yeah, I know Stadia videos got deleted after a bit (actually I remember accidentally deleting the one I attached to another bug ticket, so I understand what you mean :slight_smile: ). I cannot download the one which was made by Ekelrock though. I asked him in the Discord, let’s hope he can attach video either here or in discord (not sure about size limits and so)

These are two times when bug happened on the same place :


The complete video weights more than 4Mb and cannot attach here, but here’s link to discord with it:

1 Like