Voxel Meshes with Collision Disabled still collide with Raycasts

Describe the bug:
Voxel Meshes with Collision Disabled still collide with Raycasts. They stop colliding if you also set “Visible” to false.

Meshes with Collision Disabled don’t collide with Raycasts (as expected).

How do you cause this bug?

  • Add a Voxel Mesh
  • Set “Collision Enabled” on the Voxel Mesh to false
  • Hit the Voxel Mesh with a Raycast

Which platform: PC

Which input: keyboard + mouse

Your Crayta username: Vilva#9953

Game seen in (including “Hub” or “Editor for XYZ”): Editor for “Pogo Pirates”

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible): Every time

Time + date seen: 11.05.2022

Version number (found in Help tab in Settings): 0.f3.28.120518

Hey there @Vilva!

Thanks for this report~! :blossom:

I have entered a ticket into our system, and we will investigate this issue further. Thank you for bringing this to our attention!

1 Like

As addition to this:
Voxel Mesh collision with raycasts seems to be only controlled by “Visible”. If a Voxel Mesh has “Collision Enabled = true”, but “Visible = false”, then they will not collide with raycasts.

Hello

This should now be fixed as of 0.g1.49.126267.

Please let us know if you continue to see this issue!

1 Like

Looks like the issue has come back, will look into this one.