When you open a widget with a keypress then data-bind-mouseenter does not work, until you left-clicked at least once

Describe the bug:
When you open a widget with a keypress then the javascript event data-bind-mouseenter does not work, until you left-clicked at least once.

When playing with Controller this bug does not occur.

How do you cause this bug?

  • Open a widget on Keypress, for example by pressing “Q”
  • Hover over a HTML element with data-bind-mouseenter → The event will not trigger
  • Left-Click with your mouse
  • Hover over the HTML element again → The event does now trigger every time

Which platform: PC

Which input: keyboard + mouse

Your Crayta username: Vilva#9953

Game seen in (including “Hub” or “Editor for XYZ”): Editor for “Collectopedia Farming”

How regularly do you see this? (E.g. 2/3 times - please try 3 times if possible): Every time

Time + date seen: 01.09.2022

Version number (found in Help tab in Settings): 0.g3.9.128732

1 Like

Hi @Vilva,

Could you take a look at Cursor enabled widgets losing mouse focus and see if it sounds like the same issue you’re seeing? It sounds to me like it’s the same issue even though your steps are very slightly different (the issue being the widget not being in focus until clicked on).

1 Like

It’s the same issue. If I have my widget open and press a key (“A” for example). Then data-bind-mouseenter will stop working until I click again.

I’m guessing pressing a keyboard key to open the widget is what causes the problem then.

Ah, in that case there is already a report open covering it our side. Thanks for confirming :slight_smile: